18 de outubro de 2014
0 comentarios

Tutoriales: Solución a los problemas con juegos que usan Java en Ubuntu Linux

10/18/2014
Somos muchos los que poco a poco hemos ido migrando de Windows a Linux, y a veces no lo hacemos porque son muchos también los juegos que por una u otra causa no nos funcionan todo lo bien que esperábamos. Project Zomboid, www, y otros muchos que hacen uso de ciertas particularidades como son las librerías de Java o Flash, son de esas pequeñas joyas jugables que tienen distribución en la casa del Pingüino pero que más de una vez nos han dejado en la estacada. 


He decidido para aportar un poco de luz al camino, traer una solución. Obviamente no es la única, pero sí una de las que debemos tener muy en cuenta. Sobre todo en el caso del juego de zombis (Project Zomboid), que es con el que lo he probado, y que al menos con la última actualización ha dejado de funcionar en algunos sistemas que sólo tenían Java 6.

1-Entramos en la terminal y tecleamos:

sudo apt-get install openjdk-7-jdk openjdk-7-jre

De este modo le estamos diciendo a la distribución que se descargue la última versión de Java (la 7 en este caso).

2-Pero falta algo más. Nuestro sistema hasta ahora está usando la que tenemos por defecto. Así que debemos indicarle que use la que nos hemos descargado. Ésto es muy sencillo. Sólo tenemos que volver a teclear en la terminal la siguiente instrucción:

sudo update-alternatives --config java

3-A continuación nos saldrá una lista con las versiones instaladas, preguntándonos qué versión queremos usar por defecto. Sólo nos resta indicarle con un número la que queremos usar (la 7 en el caso sobre todo de Project Zomboid o la que sea por actualización).

Nada más. Espero que os haya solucionado más de un problema. 

¡Saludos!
Si te ha gustado, comparte la entrada :

0 comentarios:

Postar um comentário

Échale un vistazo a todas las entradas de RetroNewGames

 
Toggle Footer
Top